update gone wrong: white screen of death

christian's Avatar

christian

15 Jan, 2018 02:28 PM

Hello

i\ve updated my server to https and the secretary to 2.4, and apparently got some paths mixed up.
the system was working when it resided in a folder "new". i then moved it to "ndx", and had some trouble adjusting the move in the settings.
upon going back to new and again to nix etc, adjusting the index.php on the top hierarchy, i lost it.
now, pointing to my site www.waldvogel.com yields an entirely extremely and completely empty browser window, not even a source is available.

here's what i've done and tried:

// BEHAVIOUR
// ------------------------------------------------------------------------------------------------------------
// www.waldvogel.com/ >> empty page. not even source
// www.waldvogel.com/ndx/index.php >> empty page. not even source
// www.waldvogel.com/ndx/login.php >> works once. enter credentials, upon "submit" it loads /ndx/index.php, is empty

// HOST
// ------------------------------------------------------------------------------------------------------------
// https certificate installed >> waldvogel.com and www.waldvogel.com forwarded to https//www.waldvogel.com
// subdomains point to: /html/ >> www.waldvogel.com = www.waldvogel.com/html/
// Secretary 2.4 folder: ndx (/html/ndx)
// TEST: waldvogel.com/a13_s69.jpg works
// TEST: waldvogel.com/ndx/a13_s70.jpg works

// PERMISSIONS
// ------------------------------------------------------------------------------------------------------------
// /html/ndx and all files recursively set to 755

// INDEX (made by moving and renaming /ndx/site/site.php)
// ------------------------------------------------------------------------------------------------------------
// index.php resides in top level: www.waldvogel.com/index.php
// HQ set to path from my server root to secretary folder >> /html/ndx/
// HQ URL set to https and /ndx >> https://www.waldvogel.com/ndx/

// system/assistants/config.inc.php
// ------------------------------------------------------------------------------------------------------------
// changed skin "starling" to "labor" (my theme)
// TEST: waldvogel.com/ndx/site/themes/labor/css/main.css works

can please somebody help?
am i not registering the ndx location somewhere?

much obliged, and best wishes
-christian

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac