login information does not exist!

bastian's Avatar

bastian

07 Mar, 2016 01:43 AM

I get this error on a fresh installation of Secretary when I try to login via the /cms/login.php:

Sorry, that login information does not exist! Please try again.

The login information is the one I just created during the install right?
followed every step of the installation but alas.
trying Secretary as an alternative to indexhibit but I'm very new to the whole thing.

thanks!

  1. 1 Posted by Toshiba on 26 Mar, 2016 10:48 AM

    Toshiba's Avatar

    Same problem here.
    Clicking Submit in install.php leads to a blank page with Secretary header, attempt to login after that shouts "Sorry, that login information does not exist! Please try again."
    Tested Chrome 49 and IE 11. Database (MySql 5.1.41) is filled with content (no user is created though), so connection to DB works. site.php is created too and config.inc.php is updated as well.
    Noticed I was still running PHP 5.4, switched to 5.6 and problem still there.
    Too bad!

  2. 2 Posted by sol on 03 Apr, 2016 07:12 AM

    sol's Avatar

    Hi, same problem, I've made a couple of fresh installs to see if it's something i did wrong, but it keeps appearing :(

  3. 3 Posted by sol on 03 Apr, 2016 09:04 AM

    sol's Avatar

    This comment was split into a new discussion: login information does not exist!

    Hi again,

    i just realised that in white on white (so not readable) i have an error log, i can send, if thats useful?

    s

  4. 4 Posted by koki on 08 Apr, 2016 04:36 PM

    koki's Avatar

    i have the same problem... is there any solution yet? also tried changing the permissions from 755 to 777 (as was suggested in another thread), but the login fail message keeps appearing...

  5. 5 Posted by Sean on 20 Apr, 2016 12:15 AM

    Sean's Avatar

    Just noticed I have the same issue. Any advice? Trying a fresh install now but so far can't find anything wrong .

    Was there a recent exploit or something? Why is this happening all at the same time?

  6. 6 Posted by David on 02 Jul, 2016 09:46 AM

    David's Avatar

    Hi, I have the same problem.
    Here's the white on white error message (where site is my website name):

    "Uh-oh...
    MySQL says: FUNCTION site.password_hash does not exist"

  7. 7 Posted by wes on 04 Jul, 2016 06:07 AM

    wes's Avatar

    Same problem, fresh install 4 times, no good.

    "Sorry, that login information does not exist! Please try again."

  8. 8 Posted by Timo Menke on 05 Jul, 2016 10:23 PM

    Timo Menke's Avatar

    Same problem!!! Mac, first install, all requirements met, no problem during install, but the same screen blocking my ID/password.

  9. 9 Posted by Oskar on 30 Jul, 2016 10:30 PM

    Oskar's Avatar

    Same Problem for me. Clicking submit after entering the details on install.php gives me a blue bar at the top on a white background. No site.php is generated and no entries are added to the database.

    Hope there can be some solution!

  10. 10 Posted by matthias on 01 Aug, 2016 09:21 PM

    matthias's Avatar

    same problem here! anyone ever found a solution?

  11. 11 Posted by matthias on 10 Aug, 2016 07:03 PM

    matthias's Avatar

    is this ever going to be resolved? would love to use the secretary, but now i just can't.

  12. Support Staff 12 Posted by Mikael on 07 Oct, 2016 07:28 PM

    Mikael's Avatar

    This is a odd one that has been seen a few times and is hard to troubleshoot. It often has something to do with the server configuration.

    I'm going to run some tests and see if it has to do with PHP versioning.

  13. Support Staff 13 Posted by Mikael on 07 Oct, 2016 07:32 PM

    Mikael's Avatar

    In the meantime, see if this works:

    • Create a file called config.inc.php in the [secretary_folder]/system/assistants folder
    • Paste this into and fill out the information appropriately:
    <?php
    $settings['DB_SERVER']= "your_server";
    $settings['DB_NAME']= "database_name";
    $settings['DB_USERNAME']= "database_username";
    $settings['DB_PASSWORD']= "database_password";
    
    $settings['COOKIE_TIME']= "604800";
    $settings['COOKIE_PATH']= "/";
    $settings['COOKIE_DOMAIN']= ".";
    
    $settings['SKIN']= "starling";
    ?>
    
  14. 14 Posted by wes on 11 Oct, 2016 01:17 AM

    wes's Avatar

    I was able to install and login into a new install of The Secretary 2.3 from 2012, from your GitHub page.

    https://github.com/mikaelstaer/The-Secretary/tree/edge

  15. 15 Posted by Matthias on 14 Jan, 2019 09:15 PM

    Matthias's Avatar

    After 2.5 years, I tried again. Still, same error! Suggested method above doesn't do it, config.inc.php was properly created during install.

  16. 16 Posted by Matthias on 15 Jan, 2019 02:35 PM

    Matthias's Avatar

    I looked into the database, nothing was created in the "users" table after install. I entered the user info manually from within phpMyAdmin, but still the same error comes when trying to login.
    MySQL version: 5.5
    PHP version: 7.3

    Any ideas, anyone?

  17. 17 Posted by Sean Mooney on 15 Jan, 2019 04:15 PM

    Sean Mooney's Avatar

    How did you populate the users table without a hashed password?

  18. 18 Posted by Matthias on 15 Jan, 2019 04:36 PM

    Matthias's Avatar

    I just entered it in plain text (knowing this wouldn't be right), just to see whether the output would be any different (i.e. "wrong password"). Not sure if the error messages are differentiated like this or if it would always read "login information does not exist"...

  19. 19 Posted by Sean Mooney on 15 Jan, 2019 04:52 PM

    Sean Mooney's Avatar

    Looking at the source, that's the response if it doesn't find your
    username/password combination.

    You can use this to hash your pass as sha1
    https://passwordsgenerator.net/sha1-hash-generator/ which looks to be how
    it's set up.

  20. 20 Posted by Sean Mooney on 15 Jan, 2019 05:13 PM

    Sean Mooney's Avatar

    Amending this to say to run a toLowerCase on the hash from that site. The
    Secretary appears to use lowercase characters in the DB.

    Looking at the source, that's the response if it doesn't find your
    username/password combination.

    You can use this to hash your pass as sha1
    https://passwordsgenerator.net/sha1-hash-generator/ which looks to be how
    it's set up.

  21. 21 Posted by Oskar Koliander on 15 Jan, 2019 06:15 PM

    Oskar Koliander's Avatar

    --
    Oskar Koliander

    [email blocked]
    www.oskarkoliander.com

    +45 31919943

  22. 22 Posted by Matthias on 15 Jan, 2019 07:33 PM

    Matthias's Avatar

    Thanks Sean, this really did the trick! By creating the user in the database manually, I could finally login. Really appreciate your help!

    (Now working on the various error messages concerning permissions and upload paths, but this looks like issues I should be able to resolve.)

  23. 23 Posted by Sean Mooney on 15 Jan, 2019 07:34 PM

    Sean Mooney's Avatar

    Glad it worked out!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac